aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-nmap/qpe-nmap_0.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qpe-nmap/qpe-nmap_0.02.bb')
-rw-r--r--recipes/qpe-nmap/qpe-nmap_0.02.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/qpe-nmap/qpe-nmap_0.02.bb b/recipes/qpe-nmap/qpe-nmap_0.02.bb
new file mode 100644
index 0000000000..43cd451957
--- /dev/null
+++ b/recipes/qpe-nmap/qpe-nmap_0.02.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A frontend for the nmap port scanner, Qt/Embedded Palmtop Environment"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "nmap"
+PR = "r0"
+
+SRC_URI = "http://www.bluelightning.org/qpe-nmap/files/qpe-nmap-${PV}.tar.bz2"
+
+APPNAME = "qpe-nmap"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+S = "${WORKDIR}/qpe-nmap"
+
+inherit opie
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/pics/qpe-nmap.png ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/apps/Applications/qpe-nmap.desktop ${D}${palmtopdir}/apps/Applications/
+}
+