aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-games/crossword_0.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qpe-games/crossword_0.0.3.bb')
-rw-r--r--recipes/qpe-games/crossword_0.0.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/qpe-games/crossword_0.0.3.bb b/recipes/qpe-games/crossword_0.0.3.bb
new file mode 100644
index 0000000000..3301009cc8
--- /dev/null
+++ b/recipes/qpe-games/crossword_0.0.3.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Checkers"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Robert Ernst"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Crossword.html"
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/crossword_V0.0.3.tar.gz \
+ file://crossword.patch;patch=1"
+
+PR = "r1"
+
+PV = "0.0.3"
+S = "${WORKDIR}/crossword_V${PV}"
+
+APPNAME = "crossword"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+pkg_postinst() {
+#!/bin/sh
+
+MIMEFILE=/opt/QtPalmtop/etc/mime.types
+
+grep -q application/puz $MIMEFILE 2>/dev/null || printf "application/crossword\t\tpuz tpz\n" >> $MIMEFILE
+}
+
+inherit opie