aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qhull/tetgen_1.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qhull/tetgen_1.4.2.bb')
-rw-r--r--recipes/qhull/tetgen_1.4.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/qhull/tetgen_1.4.2.bb b/recipes/qhull/tetgen_1.4.2.bb
new file mode 100644
index 0000000000..ce6feb54e7
--- /dev/null
+++ b/recipes/qhull/tetgen_1.4.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A Quality Tetrahedral Mesh Generator and Three-Dimensional Delaunay Triangulator."
+LICENSE = "MIT"
+
+SRC_URI = "http://www.wias-berlin.de/people/si/tetgen${PV}.tar.gz"
+
+S = "${WORKDIR}/tetgen${PV}"
+
+CXX += " ${LDFLAGS}"
+
+do_configure() {
+ sed -i -e s:ar\ :'${AR}'\ :g makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 tetgen ${D}${bindir}/
+}
+