aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-traits_3.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-traits_3.0.3.bb')
-rw-r--r--recipes/python/python-traits_3.0.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/python/python-traits_3.0.3.bb b/recipes/python/python-traits_3.0.3.bb
new file mode 100644
index 0000000000..9482a1b242
--- /dev/null
+++ b/recipes/python/python-traits_3.0.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Explicitly typed attributes for Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+PR = "ml0"
+
+inherit setuptools
+
+SRC_URI = "\
+ http://pypi.python.org/packages/source/T/Traits/Traits-${PV}.tar.gz \
+# file://fix-import-pyface.diff;patch=1 \
+"
+S = "${WORKDIR}/Traits-${PV}"
+
+RDEPENDS = "python-netclient"
+
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/enthought/traits/.debug"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/enthought/traits/protocols/.debug"