aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-scons_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-scons_1.3.0.bb')
-rw-r--r--recipes/python/python-scons_1.3.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/python/python-scons_1.3.0.bb b/recipes/python/python-scons_1.3.0.bb
new file mode 100644
index 0000000000..792e3a54f7
--- /dev/null
+++ b/recipes/python/python-scons_1.3.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "A Software Construction Tool"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "scons"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz;name=scons \
+ file://toolchain-from-env.SConscript \
+"
+SRC_URI[scons.md5sum] = "ad6838c867abd2ad5bf371b353d594f7"
+SRC_URI[scons.sha256sum] = "4bde47b9a40fe767f089f5996d56b6e85a2d4929309b9c07a2dff363a78b0002"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${datadir}/scons/
+ install -m 0644 ${WORKDIR}/toolchain-from-env.SConscript ${D}${datadir}/scons/
+}
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"