summaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pysqlite2_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pysqlite2_2.4.0.bb')
-rw-r--r--recipes/python/python-pysqlite2_2.4.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/python/python-pysqlite2_2.4.0.bb b/recipes/python/python-pysqlite2_2.4.0.bb
new file mode 100644
index 0000000000..24b2668ec4
--- /dev/null
+++ b/recipes/python/python-pysqlite2_2.4.0.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python interface to SQLite 3"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+DEPENDS = "sqlite3"
+SRCNAME = "pysqlite"
+PR = "ml2"
+
+SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
+ file://fix-setup.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${datadir}/doc/
+ mv ${D}${datadir}/pysqlite2-doc ${D}${datadir}/doc/${PN}
+}
+
+RDEPENDS = "\
+ python-datetime \
+ python-lang \
+ python-crypt \
+ python-io \
+ python-threading \
+ python-unittest \
+ python-zlib \
+"
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/pysqlite2/test"
+RDEPENDS_${PN}-tests = "${PN}"