aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyro_3.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pyro_3.8.1.bb')
-rw-r--r--recipes/python/python-pyro_3.8.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/python/python-pyro_3.8.1.bb b/recipes/python/python-pyro_3.8.1.bb
new file mode 100644
index 0000000000..695d8fb7aa
--- /dev/null
+++ b/recipes/python/python-pyro_3.8.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Pyro is an acronym for PYthon Remote Objects. \
+It is an advanced and powerful Distributed Object Technology \
+system written entirely in Python, that is designed to be very \
+easy to use, and is small simple and free. Written by Irmen de Jong."
+HOMEPAGE = "http://pyro.sourceforge.net"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "ml0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/pyro/Pyro-${PV}.tar.gz \
+ file://pyro-unattended-install.patch;patch=1;pnum=0 \
+"
+S = "${WORKDIR}/Pyro-${PV}"
+
+inherit distutils
+
+RDEPENDS = "\
+ python-crypt \
+ python-io \
+ python-lang \
+ python-math \
+ python-netserver \
+ python-pickle \
+ python-re \
+ python-shell \
+ python-stringold \
+ python-threading \
+"
+