summaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-native_2.6.1.bb')
-rw-r--r--recipes/python/python-native_2.6.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
new file mode 100644
index 0000000000..3ae48285b1
--- /dev/null
+++ b/recipes/python/python-native_2.6.1.bb
@@ -0,0 +1,28 @@
+require python.inc
+DEPENDS = "openssl-native bzip2-full-native"
+
+SRC_URI = "\
+ http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
+ file://04-default-is-optimized.patch;patch=1 \
+ file://10-distutils-fix-swig-parameter.patch;patch=1 \
+ file://11-distutils-never-modify-shebang-line.patch;patch=1 \
+ file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
+"
+S = "${WORKDIR}/Python-${PV}"
+
+inherit native
+
+prefix = "${STAGING_DIR_NATIVE}/${layout_prefix}"
+exec_prefix = "${STAGING_DIR_NATIVE}/${layout_exec_prefix}"
+
+EXTRA_OEMAKE = '\
+ BUILD_SYS="" \
+ HOST_SYS="" \
+ STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
+ STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
+'
+
+do_stage_append() {
+ install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+}