aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-native_2.6.1.bb')
-rw-r--r--recipes/python/python-native_2.6.1.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
index 09e8d5a151..18002df3ae 100644
--- a/recipes/python/python-native_2.6.1.bb
+++ b/recipes/python/python-native_2.6.1.bb
@@ -1,17 +1,17 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://10-distutils-fix-swig-parameter.patch;patch=1 \
- file://11-distutils-never-modify-shebang-line.patch;patch=1 \
- file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
- file://debug.patch;patch=1 \
- file://nohostlibs.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://nohostlibs.patch \
"
S = "${WORKDIR}/Python-${PV}"
@@ -25,8 +25,8 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
-do_stage_append() {
- install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+do_install_append() {
+ install -m 0755 Parser/pgen ${D}${bindir}/pgen
}
SRC_URI[md5sum] = "e81c2f0953aa60f8062c05a4673f2be0"