aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-mysqldb_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-mysqldb_1.2.1.bb')
-rw-r--r--recipes/python/python-mysqldb_1.2.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/python/python-mysqldb_1.2.1.bb b/recipes/python/python-mysqldb_1.2.1.bb
new file mode 100644
index 0000000000..9a9ca0fe56
--- /dev/null
+++ b/recipes/python/python-mysqldb_1.2.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python interface to MySQL"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "mysql"
+SRCNAME = "MySQL-python"
+
+inherit distutils
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
+ file://mysqlpath.patch;patch=1 \
+ file://site.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
+
+do_install_append() {
+ install -d ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/doc/*.txt ${D}${datadir}/doc/${PN}/
+}