aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-libgmail_0.1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-libgmail_0.1.11.bb')
-rw-r--r--recipes/python/python-libgmail_0.1.11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/python/python-libgmail_0.1.11.bb b/recipes/python/python-libgmail_0.1.11.bb
new file mode 100644
index 0000000000..b0fcb1f83f
--- /dev/null
+++ b/recipes/python/python-libgmail_0.1.11.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python Bindings for Google's Gmail Service"
+SECTION = "devel/python"
+HOMEPAGE = "http://libgmail.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "libgmail"
+PR = "ml0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils-base
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ for file in *.py
+ do
+ install -m 0755 ${file} ${D}${libdir}/${PYTHON_DIR}
+ done
+}
+
+RDEPENDS = "\
+ python-core \
+ python-netclient \
+ python-email \
+ python-mime \
+ python-pprint \
+ python-re \
+ python-pickle \
+"
+