aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-dbus_0.83.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-dbus_0.83.0.bb')
-rw-r--r--recipes/python/python-dbus_0.83.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/python/python-dbus_0.83.0.bb b/recipes/python/python-dbus_0.83.0.bb
new file mode 100644
index 0000000000..7bc81f0396
--- /dev/null
+++ b/recipes/python/python-dbus_0.83.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+PR = "ml1"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS
+export HOST_SYS
+
+do_stage() {
+ autotools_stage_all
+}
+
+RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig