aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-coherence_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-coherence_svn.bb')
-rw-r--r--recipes/python/python-coherence_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-coherence_svn.bb b/recipes/python/python-coherence_svn.bb
new file mode 100644
index 0000000000..031067672e
--- /dev/null
+++ b/recipes/python/python-coherence_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Coherence is a DLNA/UPnP mediaserver + backends"
+SECTION = "devel/python"
+LICENSE = "MIT"
+HOMEPAGE = "http://coherence.beebits.net/wiki"
+
+PR = "r1"
+
+PV = "0.6.0+svnr${SRCREV}"
+
+inherit setuptools
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-data=${datadir}"
+
+SRC_URI = "svn://coherence.beebits.net/svn/trunk;module=Coherence;proto=https"
+S = "${WORKDIR}/Coherence"
+
+FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "python-twisted-pair python-divmodepsilon python-nevow python-gst python-dbus \
+ python-configobj python-twisted python-twisted-core python-twisted-protocols python-misc \
+ python-zopeinterface zope python-modules python-pygobject python-gdata python-inotify \
+ python-divmodaxiom"
+
+