aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pyside
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pyside')
-rw-r--r--recipes/pyside/shiboken-native_1.0.2.bb9
-rw-r--r--recipes/pyside/shiboken.inc17
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/pyside/shiboken-native_1.0.2.bb b/recipes/pyside/shiboken-native_1.0.2.bb
new file mode 100644
index 0000000000..ea30143576
--- /dev/null
+++ b/recipes/pyside/shiboken-native_1.0.2.bb
@@ -0,0 +1,9 @@
+require shiboken.inc
+
+DEPENDS = "apiextractor-native generatorrunner-native python-native"
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "585aa365811575ec3b48d59ca007f6ae"
+SRC_URI[sha256sum] = "eb3eea79945a62ed2a7282b8b99d3b8011f021465bdea6a3aad9399fa52bd5fe"
+
+inherit cmake native
diff --git a/recipes/pyside/shiboken.inc b/recipes/pyside/shiboken.inc
new file mode 100644
index 0000000000..f6455f717d
--- /dev/null
+++ b/recipes/pyside/shiboken.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Shiboken is a plugin (front-end) for Generator Runner and a runtime library. It generates \
+bindings for C++ libraries using CPython source code."
+HOMEPAGE = "http://www.pyside.org"
+LICENSE = "LGPL"
+INC_PR = "r0"
+
+SRC_URI = "http://www.pyside.org/files/shiboken-${PV}.tar.bz2"
+S = "${WORKDIR}/shiboken-${PV}"
+
+# The following exports are needed to let the cmake build configuration succeed without
+# errors when detecting the correct python version
+export HOST_SYS
+export BUILD_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+