aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pulseaudio/pulseaudio-0.9.10
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pulseaudio/pulseaudio-0.9.10')
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/2113.diff19
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/2114.diff15
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/libiconv.patch22
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch24
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/libtool2.patch48
-rw-r--r--recipes/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch17
6 files changed, 145 insertions, 0 deletions
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/2113.diff b/recipes/pulseaudio/pulseaudio-0.9.10/2113.diff
new file mode 100644
index 0000000000..666ed34ad3
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/2113.diff
@@ -0,0 +1,19 @@
+from upstream svn r2113
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2112)
++++ configure.ac (wersja 2113)
+@@ -172,6 +172,12 @@
+ AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++old_LIBS=$LIBS
++LIBS="$LIBS $LIBLTDL"
++AC_CHECK_FUNCS([lt_dlmutex_register])
++LIBS=$old_LIBS
++AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
+
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/2114.diff b/recipes/pulseaudio/pulseaudio-0.9.10/2114.diff
new file mode 100644
index 0000000000..cbd82eeb84
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/2114.diff
@@ -0,0 +1,15 @@
+from upstream svn r2114
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2113)
++++ configure.ac (wersja 2114)
+@@ -176,7 +176,7 @@
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+-AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
+
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/libiconv.patch b/recipes/pulseaudio/pulseaudio-0.9.10/libiconv.patch
new file mode 100644
index 0000000000..273b446d78
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/libiconv.patch
@@ -0,0 +1,22 @@
+Index: pulseaudio-0.9.10/src/Makefile.am
+===================================================================
+--- pulseaudio-0.9.10.orig/src/Makefile.am 2008-07-20 13:16:51.548858829 +0200
++++ pulseaudio-0.9.10/src/Makefile.am 2008-07-20 13:43:39.842031837 +0200
+@@ -551,7 +551,7 @@
+
+ libpulse_la_CFLAGS = $(AM_CFLAGS)
+ libpulse_la_LDFLAGS = -version-info $(LIBPULSE_VERSION_INFO) -Wl,-version-script=$(srcdir)/map-file
+-libpulse_la_LIBADD = $(AM_LIBADD) $(WINSOCK_LIBS) $(LIBICONV)
++libpulse_la_LIBADD = $(AM_LIBADD) $(WINSOCK_LIBS) $(LTLIBICONV)
+
+ if HAVE_X11
+ libpulse_la_CFLAGS += $(X_CFLAGS)
+@@ -771,7 +771,7 @@
+
+ libpulsecore_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBOIL_CFLAGS)
+ libpulsecore_la_LDFLAGS = -version-info $(LIBPULSECORE_VERSION_INFO)
+-libpulsecore_la_LIBADD = $(AM_LIBADD) $(LIBLTDL) $(LIBSAMPLERATE_LIBS) $(LIBSNDFILE_LIBS) $(WINSOCK_LIBS) $(LIBOIL_LIBS) $(LIBICONV) libspeex-resampler-fixed.la libspeex-resampler-float.la libffmpeg-resampler.la
++libpulsecore_la_LIBADD = $(AM_LIBADD) $(LIBLTDL) $(LIBSAMPLERATE_LIBS) $(LIBSNDFILE_LIBS) $(WINSOCK_LIBS) $(LIBOIL_LIBS) $(LTLIBICONV) libspeex-resampler-fixed.la libspeex-resampler-float.la libffmpeg-resampler.la
+
+ ###################################
+ # Plug-in support libraries #
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch b/recipes/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch
new file mode 100644
index 0000000000..4234af5f53
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch
@@ -0,0 +1,24 @@
+upstream: http://pulseaudio.org/ticket/287
+
+Index: pulseaudio-0.9.10/src/Makefile.am
+===================================================================
+--- pulseaudio-0.9.10.orig/src/Makefile.am 2008-03-30 03:43:05.000000000 +0200
++++ pulseaudio-0.9.10/src/Makefile.am 2008-05-03 11:55:46.000000000 +0200
+@@ -605,7 +605,7 @@
+
+ libpulsedsp_la_SOURCES = utils/padsp.c
+ libpulsedsp_la_CFLAGS = $(AM_CFLAGS)
+-libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la
++libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la libpulsecore.la
+ libpulsedsp_la_LDFLAGS = -avoid-version
+
+ ###################################
+@@ -888,7 +888,7 @@
+
+ libpstream_util_la_SOURCES = pulsecore/pstream-util.c pulsecore/pstream-util.h
+ libpstream_util_la_LDFLAGS = -avoid-version
+-libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la
++libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la libpulsecore.la
+
+ libpdispatch_la_SOURCES = pulsecore/pdispatch.c pulsecore/pdispatch.h
+ libpdispatch_la_LDFLAGS = -avoid-version
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/recipes/pulseaudio/pulseaudio-0.9.10/libtool2.patch
new file mode 100644
index 0000000000..9e9e5f55d3
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/libtool2.patch
@@ -0,0 +1,48 @@
+Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4
+
+---
+ configure.ac | 26 +++++++++++++++++++-------
+ 1 file changed, 19 insertions(+), 7 deletions(-)
+
+--- pulseaudio-0.9.10.orig/configure.ac
++++ pulseaudio-0.9.10/configure.ac
+@@ -242,20 +242,32 @@ if test $ret -eq 0 ; then
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+ #### libtool stuff ####
+-
+-AC_LTDL_ENABLE_INSTALL
+-AC_LIBLTDL_INSTALLABLE
+-AC_LIBTOOL_DLOPEN
+-AC_LIBTOOL_WIN32_DLL
++LT_PREREQ([2.2])
++LT_INIT([dlopen win32-dll])
+ AC_PROG_LIBTOOL
+-AC_SUBST(LTDLINCL)
+-AC_SUBST(LIBLTDL)
++#AC_SUBST(LTDLINCL)
++#AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++AC_ARG_WITH(libltdl-libs,
++ [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval)
++if test x$libltdl_libs_prefix != x; then
++ LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl"
++fi
++AC_SUBST(LIBLTDL)
++
++AC_ARG_WITH(libltdl-includes,
++ [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval)
++if test x$libltdl_prefix != x; then
++ LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so"
++fi
++AC_SUBST(LTDLINCL)
++
++
+ old_LIBS=$LIBS
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+ AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
diff --git a/recipes/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch b/recipes/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch
new file mode 100644
index 0000000000..74ea6ac060
--- /dev/null
+++ b/recipes/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch
@@ -0,0 +1,17 @@
+upstream: http://pulseaudio.org/changeset/2213
+
+Index: pulseaudio-0.9.10/src/daemon/caps.c
+===================================================================
+--- pulseaudio-0.9.10.orig/src/daemon/caps.c 2008-05-03 12:10:26.000000000 +0200
++++ pulseaudio-0.9.10/src/daemon/caps.c 2008-05-03 12:10:30.000000000 +0200
+@@ -131,9 +131,8 @@
+ return 0;
+ }
+
+-int pa_drop_caps(void) {
++void pa_drop_caps(void) {
+ pa_drop_root();
+- return 0;
+ }
+
+ #endif