aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb')
-rw-r--r--recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb b/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb
new file mode 100644
index 0000000000..4b3a3fcffe
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb
@@ -0,0 +1,31 @@
+# untested and huge change from 1.4.x
+DEFAULT_PREFERENCE = "-1"
+
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+ES2LOCATION = "${S}/gfx_rel_es2.x"
+ES3LOCATION = "${S}/gfx_rel_es3.x"
+ES5LOCATION = "${S}/gfx_rel_es5.x"
+
+require libgles-omap3.inc
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
+
+SGXPV = "4_03_00_01"
+IMGPV = "1.6.16.3977"
+BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
+ file://cputype \
+ file://rc.pvr \
+ file://sample.desktop \
+ file://99-bufferclass.rules \
+"
+
+SRC_URI[md5sum] = "4163ee51bc05689b6f61e7eadf5ab9cf"
+SRC_URI[sha256sum] = "1afe0dc4974c3c0a0ccf267a531d0964459d1cdf1929e732958230641973da94"
+
+S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
+