aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php/php-5.2.6
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/php/php-5.2.6')
-rw-r--r--recipes/php/php-5.2.6/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.2.6/pear-makefile.patch11
-rw-r--r--recipes/php/php-5.2.6/php-m4-divert.patch83
-rw-r--r--recipes/php/php-5.2.6/string.c.patch21
4 files changed, 0 insertions, 133 deletions
diff --git a/recipes/php/php-5.2.6/acinclude-xml2-config.patch b/recipes/php/php-5.2.6/acinclude-xml2-config.patch
deleted file mode 100644
index bf519d2934..0000000000
--- a/recipes/php/php-5.2.6/acinclude-xml2-config.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
-+++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
-@@ -2359,12 +2359,9 @@
- AC_DEFUN([PHP_SETUP_LIBXML], [
- AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
- [
-- for i in $PHP_LIBXML_DIR /usr/local /usr; do
-- if test -x "$i/bin/xml2-config"; then
-- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
-- break
-- fi
-- done
-+
-+ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
-+
- ])
-
- if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.2.6/pear-makefile.patch b/recipes/php/php-5.2.6/pear-makefile.patch
deleted file mode 100644
index 26de98a48f..0000000000
--- a/recipes/php/php-5.2.6/pear-makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /pear/orig-Makefile.frag 2007-03-16 12:18:33.000000000 +0200
-+++ /pear/Makefile.frag 2007-03-16 12:35:48.000000000 +0200
-@@ -6,7 +6,7 @@
- PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=E_ALL -dmemory_limit=-1 -ddetect_unicode=0
-
- install-pear-installer: $(SAPI_CLI_PATH)
-- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
-+ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
-
- install-pear:
- @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php-5.2.6/php-m4-divert.patch b/recipes/php/php-5.2.6/php-m4-divert.patch
deleted file mode 100644
index dfc7b643e2..0000000000
--- a/recipes/php/php-5.2.6/php-m4-divert.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-Patch taken from
-
-http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
-
-diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
---- php-5.2.10.org/configure.in 2009-06-17 14:22:41.000000000 +0200
-+++ php-5.2.10/configure.in 2009-08-18 12:16:25.317640253 +0200
-@@ -1,7 +1,7 @@
- ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
- dnl ## Process this file with autoconf to produce a configure script.
-
--divert(1)
-+divert(1001)
-
- dnl ## Diversion 1 is the autoconf + automake setup phase. We also
- dnl ## set the PHP version, deal with platform-specific compile
-@@ -263,7 +263,7 @@
- sinclude(TSRM/tsrm.m4)
-
-
--divert(2)
-+divert(1002)
-
- dnl ## Diversion 2 is where we set PHP-specific options and come up
- dnl ## with reasonable default values for them. We check for pthreads here
-@@ -302,7 +302,7 @@
- PTHREADS_FLAGS
- fi
-
--divert(3)
-+divert(1003)
-
- dnl ## In diversion 3 we check for compile-time options to the PHP
- dnl ## core and how to deal with different system dependencies.
-@@ -661,7 +661,7 @@
- PHP_CRYPT_R_STYLE
- fi
-
--divert(4)
-+divert(1004)
-
- dnl ## In diversion 4 we check user-configurable general settings.
-
-@@ -902,7 +902,7 @@
- AC_MSG_RESULT([using system default])
- fi
-
--divert(5)
-+divert(1005)
-
- dnl ## In diversion 5 we check which extensions should be compiled.
- dnl ## All of these are normally in the extension directories.
-diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
---- php-5.2.10.org/ext/standard/config.m4 2007-07-11 13:56:03.000000000 +0200
-+++ php-5.2.10/ext/standard/config.m4 2009-08-18 12:16:25.317640253 +0200
-@@ -1,6 +1,6 @@
- dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
-
--divert(3)dnl
-+divert(1003)dnl
-
- dnl
- dnl Check if flush should be called explicitly after buffered io
-@@ -205,7 +205,7 @@
- AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
- AC_FUNC_FNMATCH
-
--divert(5)dnl
-+divert(1005)dnl
-
- dnl
- dnl Check for regex library type
-diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
---- php-5.2.10.org/scripts/phpize.m4 2009-06-02 21:54:22.000000000 +0200
-+++ php-5.2.10/scripts/phpize.m4 2009-08-18 12:16:25.317640253 +0200
-@@ -1,6 +1,6 @@
- dnl This file becomes configure.in for self-contained extensions.
-
--divert(1)
-+divert(1001)
-
- AC_PREREQ(2.13)
- AC_INIT(config.m4)
diff --git a/recipes/php/php-5.2.6/string.c.patch b/recipes/php/php-5.2.6/string.c.patch
deleted file mode 100644
index a24b887ac2..0000000000
--- a/recipes/php/php-5.2.6/string.c.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: php-5.2.6/ext/standard/string.c
-===================================================================
---- php-5.2.6.orig/ext/standard/string.c
-+++ php-5.2.6/ext/standard/string.c
-@@ -592,14 +592,12 @@ PHP_FUNCTION(nl_langinfo)
- #endif
- #ifdef DECIMAL_POINT
- case DECIMAL_POINT:
--#endif
--#ifdef RADIXCHAR
-+#elif RADIXCHAR
- case RADIXCHAR:
- #endif
- #ifdef THOUSANDS_SEP
- case THOUSANDS_SEP:
--#endif
--#ifdef THOUSEP
-+#elif THOUSEP
- case THOUSEP:
- #endif
- #ifdef GROUPING