aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pf_ring/libpfring_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pf_ring/libpfring_svn.bb')
-rw-r--r--recipes/pf_ring/libpfring_svn.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/pf_ring/libpfring_svn.bb b/recipes/pf_ring/libpfring_svn.bb
new file mode 100644
index 0000000000..07c7d259a4
--- /dev/null
+++ b/recipes/pf_ring/libpfring_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "PF_RING is a new type of network socket that dramatically improves the packet capture speed, this package contains userspace library for interaction with kernel PF_RING module"
+SECTION = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.ntop.org/PF_RING.html"
+DEPENDS += "pf-ring"
+PV = "4.4.0+svnr${SRCPV}"
+
+S = "${WORKDIR}/lib"
+
+SRCREV = "4326"
+SRC_URI = " \
+ svn://svn.ntop.org/svn/ntop/trunk/PF_RING/userland;module=lib;proto=https \
+ file://libpfring-makefile-fixes.patch;striplevel=0 \
+ "
+
+CFLAGS += "-fPIC"
+LDFLAGS += "-shared"
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+RRECOMMENDS_${PN} = "pf-ring"