aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl-native_5.8.4.bb')
-rw-r--r--recipes/perl/perl-native_5.8.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/perl/perl-native_5.8.4.bb b/recipes/perl/perl-native_5.8.4.bb
new file mode 100644
index 0000000000..69555e0fac
--- /dev/null
+++ b/recipes/perl/perl-native_5.8.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Perl is a popular scripting language."
+HOMEPAGE = "http://www.perl.org/"
+LICENSE = "Artistic|GPL"
+PR = "r3"
+
+SECTION = "libs"
+inherit native
+
+DEPENDS = "virtual/db-native gdbm-native"
+
+SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
+S = "${WORKDIR}/perl-${PV}"
+
+do_configure () {
+ ./Configure \
+ -Dcc="${CC}" \
+ -Dcflags="${CFLAGS}" \
+ -Dldflags="${LDFLAGS}" \
+ -Dusethreads \
+ -Duselargefiles \
+ -Dprefix=${prefix} \
+ -Dvendorprefix=${prefix} \
+ -Dsiteprefix=${prefix}/local \
+ -Dman1ext=1 \
+ -Dman3ext=3perl \
+ -Uafs \
+ -Ud_csh \
+ -Uusesfio \
+ -Uusenm -des
+ sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
+ s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
+ mv config.sh.new config.sh
+}