aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pango
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pango')
-rw-r--r--recipes/pango/pangomm_2.26.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/pango/pangomm_2.26.0.bb b/recipes/pango/pangomm_2.26.0.bb
new file mode 100644
index 0000000000..127daa5d50
--- /dev/null
+++ b/recipes/pango/pangomm_2.26.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "C++ bindings for the pango library."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "cairomm glibmm"
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.bz2"
+
+inherit autotools flow-lossage
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/*/include/"
+
+EXTRA_OECONF = " --disable-documentation "
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage () {
+ autotools_stage_all
+}