aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch')
-rw-r--r--recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch b/recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch
new file mode 100644
index 0000000000..02ce26ec90
--- /dev/null
+++ b/recipes/pacemaker/pacemaker-1.0.9.1/fix-header-defs-lookup.patch
@@ -0,0 +1,16 @@
+Index: Pacemaker-1-0-Pacemaker-1.0.8/configure.ac
+===================================================================
+--- Pacemaker-1-0-Pacemaker-1.0.8.orig/configure.ac 2010-04-06 13:08:53.000000000 +0400
++++ Pacemaker-1-0-Pacemaker-1.0.8/configure.ac 2010-04-06 13:08:58.000000000 +0400
+@@ -106,9 +106,8 @@
+ Cfile=/tmp/extract_define.$2.${$}
+ printf "#include <stdio.h>\n" > ${Cfile}.c
+ printf "#include <%s>\n" $1 >> ${Cfile}.c
+- printf "int main(int argc, char **argv) { printf(\"%%s\", %s); return 0; }\n" $2 >> ${Cfile}.c
+- $CC $CFLAGS ${Cfile}.c -o ${Cfile}
+- value=`${Cfile}`
++ printf "\"%s\":%s\n" $2 $2 >> ${Cfile}.c
++ value=`$CC $CFLAGS -E ${Cfile}.c | grep \"$2\" | cut -f 2 -d ':' | sed 's,^",,' | sed 's,"$,,'`
+ AC_MSG_RESULT($value)
+ printf $value
+ rm -f ${Cfile}.c ${Cfile}