aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg-utils/opkg-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opkg-utils/opkg-utils_git.bb')
-rw-r--r--recipes/opkg-utils/opkg-utils_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/opkg-utils/opkg-utils_git.bb b/recipes/opkg-utils/opkg-utils_git.bb
new file mode 100644
index 0000000000..997b292b57
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "OPKG Package Manager Utilities"
+SECTION = "base"
+HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
+RDEPENDS_${PN} = "python"
+RDEPENDS_${PN}_virtclass-native = ""
+SRCREV = "44df9dd3dc411ca1255cb4b23bde7eb71aed4778"
+PV = "0.1.8+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=git \
+ "
+
+S = "${WORKDIR}/git"
+
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES_virtclass-native = ""
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native"
+TARGET_CC_ARCH += "${LDFLAGS}"