aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openal/openal_0.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openal/openal_0.0.8.bb')
-rw-r--r--recipes/openal/openal_0.0.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/openal/openal_0.0.8.bb b/recipes/openal/openal_0.0.8.bb
new file mode 100644
index 0000000000..280c5d75e8
--- /dev/null
+++ b/recipes/openal/openal_0.0.8.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
+DEPENDS = "alsa-lib virtual/libsdl libvorbis"
+
+SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
+ file://void-workaround.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
+ --disable-smpeg --disable-arts"
+
+do_configure_append () {
+ sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libopenal"
+
+FILES_libopenal += "${libdir}/libopenal.so.*"
+FILES_openal-dev += "${bindir}/openal-config"
+FILES_openal = ""