aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ogre/freeimage_3.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ogre/freeimage_3.11.0.bb')
-rw-r--r--recipes/ogre/freeimage_3.11.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ogre/freeimage_3.11.0.bb b/recipes/ogre/freeimage_3.11.0.bb
new file mode 100644
index 0000000000..8281aaf371
--- /dev/null
+++ b/recipes/ogre/freeimage_3.11.0.bb
@@ -0,0 +1,29 @@
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freeimage/FreeImage3110.zip"
+
+S = "${WORKDIR}/FreeImage/"
+
+do_configure() {
+ sed -i -e /^CC/d \
+ -e /^CXX\ /d \
+ -e /^AR/d \
+ -e /^INCDIR\ /d \
+ -e /^INSTALLDIR\ /d \
+ -e s:'-o root -g root'::g \
+ -e /ldconfig/d \
+ ${S}/Makefile.gnu
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ oe_runmake INSTALLDIR="${D}${libdir}" INCDIR="${D}${includedir}" install
+}
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}
+ oe_runmake INSTALLDIR="${STAGING_LIBDIR}" INCDIR="${STAGING_INCDIR}" install
+}
+