aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obexftp/obexftp_0.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obexftp/obexftp_0.22.bb')
-rw-r--r--recipes/obexftp/obexftp_0.22.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/obexftp/obexftp_0.22.bb b/recipes/obexftp/obexftp_0.22.bb
new file mode 100644
index 0000000000..89e10a72af
--- /dev/null
+++ b/recipes/obexftp/obexftp_0.22.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "OBEX Ftp Client based on openobex."
+SECTION = "console/network"
+HOMEPAGE = "http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+LICENSE = "GPL"
+DEPENDS = "openobex bluez-libs libusb virtual/libiconv"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-bluetooth \
+ --disable-swig \
+ --disable-perl \
+ --disable-python \
+ --disable-tcl \
+ --disable-ruby \
+ --disable-builddocs \
+ --disable-rpath \
+ "
+
+PARALLEL_MAKE = ""
+
+LEAD_SONAME = "libobexftp.so"
+
+do_stage() {
+ autotools_stage_all
+}
+