aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb')
-rw-r--r--recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb b/recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb
new file mode 100644
index 0000000000..713a54a5ed
--- /dev/null
+++ b/recipes/nonworking/maemo-mapper/maemo-mapper_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GPS navigation/map display software"
+LICENSE = "GPL"
+DEPENDS = "gdbm libconic sqlite3 gtk+ libhildonfm libosso osso-ic-oss libosso-help gnome-vfs dbus bluez-libs"
+RDEPENDS_${PN} = "bluez-utils"
+RRECOMMENDS_${PN} = "gpsd flite"
+SRCREV = "118"
+PV = "2.0.3+svnr${SRCPV}"
+PR = "r3"
+
+SRC_URI = "svn://garage.maemo.org/svn/maemo-mapper;proto=https;module=trunk \
+ file://mapper-hildon1.diff;maxrev=108"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ mv ${D}/maemo-mapper.desktop ${D}${datadir}/applications/
+}
+
+#FILES_${PN} += "${datadir}/icons"