aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nis/nis.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nis/nis.inc')
-rw-r--r--recipes/nis/nis.inc34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/nis/nis.inc b/recipes/nis/nis.inc
new file mode 100644
index 0000000000..90f7ff50a0
--- /dev/null
+++ b/recipes/nis/nis.inc
@@ -0,0 +1,34 @@
+# This include file contains global definitions for the
+# various NIS packages.
+#
+# These packages will only function correctly with glibc -
+# the rpcsvc functionality is not present in uclibc
+DESCRIPTION ?= "NIS Server and Tools"
+HOMEPAGE ?= "http://www.linux-nis.org/nis/"
+SECTION ?= "console/network"
+PRIORITY ?= "optional"
+LICENSE ?= "GPLv2"
+
+# Override these *after* the include file if necessary!
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/${P}.tar.bz2"
+
+inherit autotools gettext
+
+# install is broken because src/Makefile heroically adds '-s'
+# to the install flags - passing -s to the build /usr/bin/install!
+# install-strip gets it right but installs ypbind -m <default>,
+# not -m 555. In an OE build this is not, so far as I can see,
+# a security problem (and this fix to the build problem is *much*
+# easier and more maintainable.)
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install-strip
+}
+
+# An attempt to build on uclibc will fail, causing annoyance,
+# so force the package to be skipped here (this will cause a
+# 'nothing provides' error)
+python () {
+ os = bb.data.getVar("TARGET_OS", d, 1)
+ if os == "linux-uclibc":
+ raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
+}