aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ngrep/ngrep_1.42.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ngrep/ngrep_1.42.bb')
-rw-r--r--recipes/ngrep/ngrep_1.42.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ngrep/ngrep_1.42.bb b/recipes/ngrep/ngrep_1.42.bb
new file mode 100644
index 0000000000..6f90965860
--- /dev/null
+++ b/recipes/ngrep/ngrep_1.42.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ngrep strives to provide most of GNU grep's \
+common features, applying them to the network layer."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "libpcap libpcre"
+LICENSE="ngrep"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ngrep/ngrep-${PV}.tar.bz2 \
+ file://use-our-pcre.patch;patch=1"
+
+EXTRA_OECONF = "--with-restart --enable-pcre --with-pcap-includes=${STAGING_INCDIR}"
+EXTRA_OEMAKE = "INCLUDES=${S}"
+
+inherit autotools
+
+CFLAGS += '-DDROPPRIVS_ONLY_ROOT=0 -DDROPPRIVS_USER=\""nobody\"" -DUSE_DROPPRIVS=1'
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ngrep ${D}${bindir}/
+}