aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/neon/neon_0.26.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/neon/neon_0.26.0.bb')
-rw-r--r--recipes/neon/neon_0.26.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/neon/neon_0.26.0.bb b/recipes/neon/neon_0.26.0.bb
new file mode 100644
index 0000000000..3a234851aa
--- /dev/null
+++ b/recipes/neon/neon_0.26.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "zlib libxml2 expat time gnutls"
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
+
+do_stage () {
+ autotools_stage_all
+}