aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mythtv/gmyth_0.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mythtv/gmyth_0.7.1.bb')
-rw-r--r--recipes/mythtv/gmyth_0.7.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mythtv/gmyth_0.7.1.bb b/recipes/mythtv/gmyth_0.7.1.bb
new file mode 100644
index 0000000000..71c5ddb143
--- /dev/null
+++ b/recipes/mythtv/gmyth_0.7.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GMyth is a library to access MythTV backend services."
+LICENSE = "LGPLv2""
+HOMEPAGE = "http://gmyth.sourceforge.net/wiki/index.php/Main_Page"
+DEPENDS = "mythtv curl libxml2 glib-2.0"
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gmyth/${PN}-${PV}.tar.gz"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ gmyth.pc
+}
+
+do_stage() {
+ autotools_stage_all
+}
+