summaryrefslogtreecommitdiffstats
path: root/recipes/mokosuite2/mokohome_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mokosuite2/mokohome_git.bb')
-rw-r--r--recipes/mokosuite2/mokohome_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mokosuite2/mokohome_git.bb b/recipes/mokosuite2/mokohome_git.bb
new file mode 100644
index 0000000000..33b74bf9b7
--- /dev/null
+++ b/recipes/mokosuite2/mokohome_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - desktop and home screen"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "c7126d6a754b58add0f76d1994a92e2be60705df"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokohome.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/home"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/home/theme.edj
+}