aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mml-widget/gtkmathview_0.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mml-widget/gtkmathview_0.8.0.bb')
-rw-r--r--recipes/mml-widget/gtkmathview_0.8.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/mml-widget/gtkmathview_0.8.0.bb b/recipes/mml-widget/gtkmathview_0.8.0.bb
new file mode 100644
index 0000000000..2fe48ea872
--- /dev/null
+++ b/recipes/mml-widget/gtkmathview_0.8.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
+DEPENDS = "t1lib gtk+ popt libxslt libxml2"
+
+SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
+ file://mathview-gcc43x.diff;patch=1 \
+ "
+
+inherit autotools
+AUTOTOOLS_STAGE_PKGCONFIG = 1
+
+EXTRA_OECONF = "--disable-binreloc"
+
+do_configure_prepend() {
+ sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+ for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
+ sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
+ done
+}
+