aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/memtester/memtester_4.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/memtester/memtester_4.1.3.bb')
-rw-r--r--recipes/memtester/memtester_4.1.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/memtester/memtester_4.1.3.bb b/recipes/memtester/memtester_4.1.3.bb
new file mode 100644
index 0000000000..721345d37c
--- /dev/null
+++ b/recipes/memtester/memtester_4.1.3.bb
@@ -0,0 +1,25 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utility to test for faulty memory subsystem"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
+SRC_URI += "file://Makefile.patch"
+
+SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38"
+SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6"
+
+S = "${WORKDIR}/memtester-${PV}"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}
+