aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb')
-rw-r--r--recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..2fd7926707
--- /dev/null
+++ b/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+LICENSE = "MIT"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+
+DEPENDS = "matchbox xmodmap"
+
+PR = "r7"
+
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://xrandr.png"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+}
+
+#The package contains ashellscript, a .desktop file and a png
+PACKAGE_ARCH = "all"
+