summaryrefslogtreecommitdiffstats
path: root/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch')
-rw-r--r--recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch b/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch
new file mode 100644
index 0000000000..ed805575ba
--- /dev/null
+++ b/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch
@@ -0,0 +1,20 @@
+--- madwifi-trunk-r3837-20080802/ath_hal/Makefile.orig 2008-09-06 22:23:21.000000000 -0500
++++ madwifi-trunk-r3837-20080802/ath_hal/Makefile 2008-09-06 22:29:50.000000000 -0500
+@@ -82,12 +82,16 @@ endif
+ quiet_cmd_uudecode = UUDECODE $@
+ cmd_uudecode = $(obj)/uudecode -o $@ $<
+
+-$(filter-out ./,$(obj)/)$(HALBIN): $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
++$(obj)/wackelf: $(HAL)/public/wackelf.c
++ $(HOSTCC) $(HOSTCFLAGS) -o $@ $<
++
++$(filter-out ./,$(obj)/)$(HALBIN): $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode $(obj)/wackelf
+ ifdef LINUX24
+ $(cmd_uudecode)
+ else
+ $(call if_changed,uudecode)
+ endif
++ $(obj)/wackelf -fpa $@
+
+ # Replace as many hashed names as possible with meaningful
+ # ones in the symbol table of the binary kernel module for HAL.