aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua/lua5.1-native_5.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lua/lua5.1-native_5.1.4.bb')
-rw-r--r--recipes/lua/lua5.1-native_5.1.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/lua/lua5.1-native_5.1.4.bb b/recipes/lua/lua5.1-native_5.1.4.bb
new file mode 100644
index 0000000000..35afb55662
--- /dev/null
+++ b/recipes/lua/lua5.1-native_5.1.4.bb
@@ -0,0 +1,11 @@
+require lua5.1_${PV}.bb
+inherit native
+
+DEPENDS = "readline-native"
+
+do_stage () {
+ oe_libinstall -C src liblua ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/
+ install -m 0644 src/lua.h src/luaconf.h src/lualib.h src/lauxlib.h ${STAGING_INCDIR}/
+}
+