aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltp/ltp-20070228/cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ltp/ltp-20070228/cross-compile.patch')
-rw-r--r--recipes/ltp/ltp-20070228/cross-compile.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/ltp/ltp-20070228/cross-compile.patch b/recipes/ltp/ltp-20070228/cross-compile.patch
new file mode 100644
index 0000000000..ae956fd8bf
--- /dev/null
+++ b/recipes/ltp/ltp-20070228/cross-compile.patch
@@ -0,0 +1,51 @@
+diff -urN ltp-full-20060615.orig/Makefile ltp-full-20060615/Makefile
+--- ltp-full-20060615.orig/Makefile 2006-02-24 10:16:55.000000000 +0800
++++ ltp-full-20060615/Makefile 2006-07-07 17:10:22.000000000 +0800
+@@ -30,11 +30,12 @@
+ endif
+ ifdef CROSS_COMPILER
+ CC=$(CROSS_COMPILER)gcc
++CPP=$(CROSS_COMPILER)g++
+ AR=$(CROSS_COMPILER)ar
+ endif
+
+ export CFLAGS += -Wall $(CROSS_CFLAGS)
+-export CC AR LDFLAGS
++export CC AR LDFLAGS CPP
+
+ -include config.mk
+
+diff -urN ltp-full-20060615.orig/testcases/ballista/ballista/Makefile ltp-full-20060615/testcases/ballista/ballista/Makefile
+--- ltp-full-20060615.orig/testcases/ballista/ballista/Makefile 2006-02-23 08:33:27.000000000 +0800
++++ ltp-full-20060615/testcases/ballista/ballista/Makefile 2006-07-07 17:11:29.000000000 +0800
+@@ -24,7 +24,7 @@
+ ########################
+
+ # compiler info for the host
+-CC = g++ -Wno-deprecated
++CC = $(CPP) -Wno-deprecated
+ CFLAGS = -w -O ${TARGET_DEF}
+ CLIBS = -lpthread -ldl -lnsl -rdynamic
+ TEST_MAN_FILE = selfHost
+diff -urN ltp-full-20060615.orig/testcases/network/nfs/cthon04/tests.init ltp-full-20060615/testcases/network/nfs/cthon04/tests.init
+--- ltp-full-20060615.orig/testcases/network/nfs/cthon04/tests.init 2005-09-01 04:27:17.000000000 +0800
++++ ltp-full-20060615/testcases/network/nfs/cthon04/tests.init 2006-07-07 17:12:28.000000000 +0800
+@@ -73,7 +73,7 @@
+ # Tru64 UNIX
+ # SVR4
+ # Linux
+-PATH=/bin:/usr/bin:/usr/ucb:/usr/ccs/bin:/sbin:/usr/sbin:.
++#PATH=/bin:/usr/bin:/usr/ucb:/usr/ccs/bin:/sbin:/usr/sbin:.
+
+ # Use this path for:
+ # DG/UX
+@@ -104,7 +104,9 @@
+ # Do not remove the following three lines. They may be overridden by
+ # other configuration parameters lower in this file, but these three
+ # variables must be defined.
++ifndef CC
+ CC=cc
++endif
+ CFLAGS=
+ LIBS=
+ LOCKTESTS=tlock