aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.31/boc01/011-091028-gpio.patch9
-rw-r--r--recipes/linux/linux-2.6.31/boc01/012-091019-capsense.patch19
-rw-r--r--recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch45
-rw-r--r--recipes/linux/linux-2.6.31/boc01/defconfig4
4 files changed, 45 insertions, 32 deletions
diff --git a/recipes/linux/linux-2.6.31/boc01/011-091028-gpio.patch b/recipes/linux/linux-2.6.31/boc01/011-091028-gpio.patch
index c71f9e6289..12f5435599 100644
--- a/recipes/linux/linux-2.6.31/boc01/011-091028-gpio.patch
+++ b/recipes/linux/linux-2.6.31/boc01/011-091028-gpio.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.31/arch/powerpc/platforms/83xx/mpc831x_rdb.c
===================================================================
---- linux-2.6.31.orig/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-10-29 16:31:14.000000000 +0100
-+++ linux-2.6.31/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-10-29 17:23:51.000000000 +0100
+--- linux-2.6.31.orig/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-09-10 00:13:59.000000000 +0200
++++ linux-2.6.31/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-10-30 12:44:52.000000000 +0100
@@ -13,6 +13,7 @@
* option) any later version.
*/
@@ -18,7 +18,7 @@ Index: linux-2.6.31/arch/powerpc/platforms/83xx/mpc831x_rdb.c
#include "mpc83xx.h"
-@@ -79,7 +81,22 @@
+@@ -79,7 +81,21 @@
static int __init declare_of_platform_devices(void)
{
@@ -29,13 +29,12 @@ Index: linux-2.6.31/arch/powerpc/platforms/83xx/mpc831x_rdb.c
+
of_platform_bus_probe(NULL, of_bus_ids, NULL);
+
-+ /* activate USB, RFID and touch board */
++ /* activate USB and RFID */
+ np = of_find_compatible_node(NULL, NULL, "fsl,mpc8313-exio");
+ if (np)
+ {
+ gpio_direction_output(217, 1); // EXIO1 : USB
+ gpio_direction_output(219, 1); // EXIO3 : RFID
-+ gpio_direction_output(220, 1); // EXIO4 : Touch board
+ of_node_put(np);
+ }
return 0;
diff --git a/recipes/linux/linux-2.6.31/boc01/012-091019-capsense.patch b/recipes/linux/linux-2.6.31/boc01/012-091019-capsense.patch
index d82f8b1e54..ae5428ddd0 100644
--- a/recipes/linux/linux-2.6.31/boc01/012-091019-capsense.patch
+++ b/recipes/linux/linux-2.6.31/boc01/012-091019-capsense.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.31/drivers/input/misc/Kconfig
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-19 16:32:13.000000000 +0200
-+++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-19 16:49:22.000000000 +0200
+--- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-30 12:50:24.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-30 13:20:50.000000000 +0100
@@ -269,4 +269,14 @@
To compile this driver as a module, choose M here: the
@@ -19,8 +19,8 @@ Index: linux-2.6.31/drivers/input/misc/Kconfig
endif
Index: linux-2.6.31/drivers/input/misc/Makefile
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-19 16:32:13.000000000 +0200
-+++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-19 16:49:22.000000000 +0200
+--- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-30 12:50:24.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-30 13:20:50.000000000 +0100
@@ -26,3 +26,4 @@
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
@@ -29,8 +29,8 @@ Index: linux-2.6.31/drivers/input/misc/Makefile
Index: linux-2.6.31/drivers/input/misc/capsense-btns.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.31/drivers/input/misc/capsense-btns.c 2009-10-19 16:49:22.000000000 +0200
-@@ -0,0 +1,440 @@
++++ linux-2.6.31/drivers/input/misc/capsense-btns.c 2009-10-30 13:21:11.000000000 +0100
+@@ -0,0 +1,443 @@
+/*
+ * CAPSENSE Interface driver
+ *
@@ -185,9 +185,12 @@ Index: linux-2.6.31/drivers/input/misc/capsense-btns.c
+ changed = capsense->key_state ^ new_state;
+ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
+ if (changed & (1 << i))
++ {
++ input_event(dev->input, EV_MSC, MSC_SCAN, i);
+ input_report_key(dev->input, input_keymap[i], (new_state & (1 << i)));
++ input_sync(dev->input);
++ }
+ capsense->key_state = new_state;
-+ input_sync(dev->input);
+}
+
+
@@ -474,7 +477,7 @@ Index: linux-2.6.31/drivers/input/misc/capsense-btns.c
Index: linux-2.6.31/drivers/input/misc/capsense-procfs.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.31/drivers/input/misc/capsense-procfs.c 2009-10-19 16:50:35.000000000 +0200
++++ linux-2.6.31/drivers/input/misc/capsense-procfs.c 2009-10-30 13:20:03.000000000 +0100
@@ -0,0 +1,380 @@
+/*
+ * CAPSENSE Interface driver
diff --git a/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch b/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
index 9e56ad12b0..6b2dba1337 100644
--- a/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
+++ b/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.31/drivers/input/misc/Kconfig
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-30 11:08:24.000000000 +0100
-+++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-30 11:08:32.000000000 +0100
+--- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-30 14:22:53.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-30 14:22:53.000000000 +0100
@@ -270,6 +270,13 @@
To compile this driver as a module, choose M here: the
module will be called dm355evm_keys.
@@ -18,8 +18,8 @@ Index: linux-2.6.31/drivers/input/misc/Kconfig
select INPUT_POLLDEV
Index: linux-2.6.31/drivers/input/misc/Makefile
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-30 11:08:51.000000000 +0100
-+++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-30 11:08:58.000000000 +0100
+--- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-30 14:22:53.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-30 14:22:53.000000000 +0100
@@ -26,4 +26,5 @@
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
@@ -29,8 +29,8 @@ Index: linux-2.6.31/drivers/input/misc/Makefile
Index: linux-2.6.31/drivers/input/misc/boc-btns.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.31/drivers/input/misc/boc-btns.c 2009-10-30 11:57:13.000000000 +0100
-@@ -0,0 +1,200 @@
++++ linux-2.6.31/drivers/input/misc/boc-btns.c 2009-10-30 14:24:42.000000000 +0100
+@@ -0,0 +1,211 @@
+/*
+ * Buttons for BoC
+ *
@@ -61,17 +61,23 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+
+#define BUTTONS_POLL_INTERVAL 30 /* msec */
+
-+static unsigned char input_gpio[] = {
-+ 231, // reset button
++struct input_button {
++ unsigned char gpio;
++ unsigned char active_low;
++};
++
++static struct input_button input_buttons[] = {
++ { 220, 1 }, // WPS button (active low)
++ { 231, 0 }, // reset button
+};
+
+static unsigned short input_keymap[] = {
-+ KEY_ESC,
++ KEY_F2,
++ KEY_F3,
+};
+
+struct buttons_dev {
+ struct input_polled_dev *poll_dev;
-+ unsigned short keymap[ARRAY_SIZE(input_keymap)];
+ int state[ARRAY_SIZE(input_keymap)];
+};
+
@@ -88,7 +94,9 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+ // read GPIO
+ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
+ {
-+ value = gpio_get_value(input_gpio[i]);
++ value = gpio_get_value(input_buttons[i].gpio) ? 1 : 0;
++ if (input_buttons[i].active_low)
++ value = !value;
+ if (value != bdev->state[i])
+ {
+ input_event(input, EV_MSC, MSC_SCAN, i);
@@ -112,7 +120,7 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+
+ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
+ {
-+ if (gpio_request(input_gpio[i], NULL) < 0)
++ if (gpio_request(input_buttons[i].gpio, NULL) < 0)
+ return -ENODEV;
+ }
+
@@ -126,8 +134,6 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+ goto out_allocated;
+ }
+
-+ memcpy(bdev->keymap, input_keymap, sizeof(bdev->keymap));
-+
+ poll_dev->private = bdev;
+ poll_dev->poll = handle_buttons;
+ poll_dev->poll_interval = BUTTONS_POLL_INTERVAL;
@@ -138,12 +144,17 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+ input->id.bustype = BUS_HOST;
+ input->dev.parent = &pdev->dev;
+
-+ input->keycode = bdev->keymap;
-+ input->keycodemax = ARRAY_SIZE(bdev->keymap);
++ input->keycode = input_keymap;
++ input->keycodemax = ARRAY_SIZE(input_keymap);
+ input->keycodesize = sizeof(unsigned short);
+
+ input_set_capability(input, EV_MSC, MSC_SCAN);
+ set_bit(EV_KEY, input->evbit);
++ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
++ {
++ set_bit(input_keymap[i], input->keybit);
++ bdev->state[i] = 0;
++ }
+
+ bdev->poll_dev = poll_dev;
+ dev_set_drvdata(&pdev->dev, bdev);
@@ -173,7 +184,7 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+ dev_set_drvdata(dev, NULL);
+
+ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
-+ gpio_free(input_gpio[i]);
++ gpio_free(input_buttons[i].gpio);
+
+ return 0;
+}
diff --git a/recipes/linux/linux-2.6.31/boc01/defconfig b/recipes/linux/linux-2.6.31/boc01/defconfig
index 56e10a04a0..ae2b9b510e 100644
--- a/recipes/linux/linux-2.6.31/boc01/defconfig
+++ b/recipes/linux/linux-2.6.31/boc01/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.31.3
-# Wed Oct 28 11:48:05 2009
+# Fri Oct 30 14:31:19 2009
#
# CONFIG_PPC64 is not set
@@ -1061,7 +1061,7 @@ CONFIG_INPUT_POLLDEV=y
# CONFIG_INPUT_MOUSEDEV is not set
# CONFIG_INPUT_JOYDEV is not set
CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_EVBUG=y
+# CONFIG_INPUT_EVBUG is not set
#
# Input Device Drivers