aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux_2.6.32.bb')
-rw-r--r--recipes/linux/linux_2.6.32.bb23
1 files changed, 22 insertions, 1 deletions
diff --git a/recipes/linux/linux_2.6.32.bb b/recipes/linux/linux_2.6.32.bb
index 7f2ef0a2e8..be3d8ad7c6 100644
--- a/recipes/linux/linux_2.6.32.bb
+++ b/recipes/linux/linux_2.6.32.bb
@@ -1,14 +1,21 @@
require linux.inc
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/linux-${PV}"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_simone = "1"
+DEFAULT_PREFERENCE_akita = "-1"
+DEFAULT_PREFERENCE_c7x0 = "-1"
+DEFAULT_PREFERENCE_collie = "-1"
+DEFAULT_PREFERENCE_poodle = "-1"
+DEFAULT_PREFERENCE_spitz = "-1"
+DEFAULT_PREFERENCE_tosa = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.1.bz2;patch=1 \
file://defconfig"
SRC_URI[kernel.md5sum] = "260551284ac224c3a43c4adac7df4879"
@@ -24,3 +31,17 @@ SRC_URI_append_simone = " \
file://ep93xx/ep93xx-touchscreen.patch;patch=1 \
file://ep93xx/ep93xx-spi.patch;patch=1 \
file://ep93xx/ep93xx-cpuinfo.patch;patch=1 "
+
+# Zaurus family bootloader patches
+RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
+ZAURUSPATCHES = " ${RPSRC}/pxa-linking-bug-r1.patch;patch=1;status=unmergable;name=pxa-linking-bug-r1 "
+SRC_URI[pxa-linking-bug-r1.md5sum] = "1e2a99787260c3566033e7f41180e2c8"
+SRC_URI[pxa-linking-bug-r1.sha256sum] = "785d2680022325ad54c1593082dce902f5fee31dae4c1922ba43956b1dcfcd8b"
+
+# Machine specific patches
+SRC_URI_append_akita = "${ZAURUSPATCHES}"
+SRC_URI_append_c7x0 = "${ZAURUSPATCHES}"
+SRC_URI_append_collie = "${ZAURUSPATCHES}"
+SRC_URI_append_poodle = "${ZAURUSPATCHES}"
+SRC_URI_append_spitz = "${ZAURUSPATCHES}"
+SRC_URI_append_tosa = "${ZAURUSPATCHES}"