aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-wrap-geode_2.6.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-wrap-geode_2.6.17.bb')
-rw-r--r--recipes/linux/linux-wrap-geode_2.6.17.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-wrap-geode_2.6.17.bb b/recipes/linux/linux-wrap-geode_2.6.17.bb
new file mode 100644
index 0000000000..3d9b81a936
--- /dev/null
+++ b/recipes/linux/linux-wrap-geode_2.6.17.bb
@@ -0,0 +1,22 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for PC-Engines WRAP which are \
+Geode SC1100 (i486) based wirless router appliance boards"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'i486.*-linux'
+COMPATIBLE_MACHINE = "wrap"
+
+inherit kernel
+
+ARCH = "i386"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ yes '' | oe_runmake oldconfig
+}