aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-orion_2.6.28.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-orion_2.6.28.4.bb')
-rw-r--r--recipes/linux/linux-orion_2.6.28.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-orion_2.6.28.4.bb b/recipes/linux/linux-orion_2.6.28.4.bb
new file mode 100644
index 0000000000..c0a7d3c9af
--- /dev/null
+++ b/recipes/linux/linux-orion_2.6.28.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Linux Kernel for Marvell Orion based devices"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+COMPATIBLE_MACHINE = "(dns323|mv2120|kuropro|lspro|tsx09|ts409)"
+
+require linux.inc
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.gz;patch=1 \
+ file://kuropro-foonas-mtd.patch;patch=1 \
+ file://fw-and-powerpc-install.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.28"
+
+# Fix the mach-type of orion devices - always passed 526
+SRC_URI_append_dns323 += "file://dns323.patch;patch=1"
+SRC_URI_append_mv2120 += "file://mv2120.patch;patch=1"
+SRC_URI_append_kuropro += "file://kuropro.patch;patch=1"
+SRC_URI_append_lspro += "file://lspro.patch;patch=1"
+SRC_URI_append_tsx09 += "file://tsx09.patch;patch=1"
+SRC_URI_append_ts409 += "file://ts409.patch;patch=1"
+
+KERNEL_IMAGETYPE ?= "uImage"