aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.32_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.32_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-2.6.32_git.bb74
1 files changed, 37 insertions, 37 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.32_git.bb b/recipes/linux/linux-openmoko-2.6.32_git.bb
index bb1bc50082..19171af811 100644
--- a/recipes/linux/linux-openmoko-2.6.32_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.32_git.bb
@@ -1,54 +1,54 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
-
-KERNEL_RELEASE="2.6.32.12"
+KERNEL_RELEASE="2.6.32.21"
SRCREV = "a9254be10ac2294ea20165a87c09ea6afcf66d94"
-OEV = "oe1"
+OEV = "oe3.3"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
- file://0001-Revert-s3cmci-initialize-default-platform-data-no_wp.patch;patch=1 \
+ file://0001-Revert-s3cmci-initialize-default-platform-data-no_wp.patch \
# latest stable patch for ubi fix 943e167cb3e8fb191894bde8a4a75db78531a7c8
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1;name=stablepatch \
-# build fix
- file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch;patch=1 \
-# patches from Weiss's gdrm-2.6.32 branch
- file://0002-DRM-for-platform-devices.patch;patch=1 \
- file://0003-Glamo-DRM-and-KMS-driver.patch;patch=1 \
- file://0004-Work-on-Glamo-core-for-DRM.patch;patch=1 \
- file://0005-Add-JBT6k74-hook-for-use-by-KMS.patch;patch=1 \
- file://0006-glamo-drm-use-dev_set_drvdata-instead-of-setting-dri.patch;patch=1 \
- file://0007-glamo-drm-select-DRM_KMS_HELPER-for-crtc-functions.patch;patch=1 \
- file://0008-Fix-crash-when-reading-Glamo-registers-via-sysfs.patch;patch=1 \
- file://0009-A-couple-of-GEM-refcounting-fixes.patch;patch=1 \
- file://0010-Simplify-the-JBT6k74-driver.patch;patch=1 \
- file://0011-Don-t-choke-if-userspace-provides-a-pixel-clock-valu.patch;patch=1 \
- file://0012-Report-all-FB-modes-given-by-the-lower-levels.patch;patch=1 \
- file://0013-Change-connector-type-to-LVDS.patch;patch=1 \
- file://0014-Clean-up-JBT-hooks-and-allow-resolution-switching.patch;patch=1 \
- file://0015-Enable-display-before-trying-to-set-mode-or-base.patch;patch=1 \
- file://0016-accels.patch.patch;patch=1 \
- file://0017-usbhost.patch.patch;patch=1 \
- file://0018-ar6000_delay.patch.patch;patch=1 \
- file://0019-save_regs.patch.patch;patch=1 \
- file://0020-Fix-KMS-framebuffer-physical-address.patch;patch=1 \
- file://0021-Reject-modes-with-clock-0.patch;patch=1 \
- file://0022-JBT6k74-tweaks-Make-resolution-switch-work.patch;patch=1 \
- file://0023-Remove-a-couple-of-debugging-messages.patch;patch=1 \
- file://0024-Enable-dummy-frames-when-switching-resolution.patch;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;apply=yes;name=stablepatch \
+# build fix - only when snd is as module
+ file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch \
+# fix runtime issue when built with gcc-4.5
+ file://0001-add-noinline-and-noclone-attributes-to-naked-functio.patch \
+# patches from Radek Polak used in qtmoko
+ file://0002-accels.patch.patch \
+ file://0003-usbhost.patch.patch \
+ file://0004-ar6000_delay.patch.patch \
+ file://0005-save_regs.patch.patch \
+# patches from Weiss's gdrm-for-merging branch
+ file://0007-DRM-for-platform-devices.patch \
+ file://0008-Glamo-DRM-and-KMS-driver.patch \
+ file://0009-Work-on-Glamo-core-for-DRM.patch \
+ file://0010-JBT6k74-work-for-KMS.patch \
+ file://0011-Fix-crash-when-reading-Glamo-registers-via-sysfs.patch \
+ file://0012-Fix-dynamic-command-queue-allocation.patch \
+ file://0013-Debug-statements-for-testing.patch \
+ file://0014-Fix-claim-of-2D-register-resource.patch \
+# fix HS Jack
+ file://0019-wm8753-use-snd_soc_jack-on-neo1973.patch \
+# fix for lost touchscreen https://docs.openmoko.org/trac/ticket/2328
+ file://0017-s3c2410_ts-ignore-unexpected-interrupts.patch \
+# fix WS
+ file://0016-jbt6k74-fix-WS.patch \
+ file://0018-glamo-core-initialize-engine-states-as-disabled.patch \
+# faster glamo
+ file://0020-mfd-glamo-Enable-FIFO-stage-for-the-LCD-engine-s-mem.patch \
+ file://0021-glamo-display-fix-WSOD-for-242-timming.patch \
+ file://defconfig \
"
-SRC_URI[stablepatch.md5sum] = "9d097d34648a1734b1a7f97c5d000f03"
-SRC_URI[stablepatch.sha256sum] = "e03ffcd2c88e936e581e5f7a7c675d11345064f2e3df96e335e5438c6593e3e7"
+SRC_URI[stablepatch.md5sum] = "29aa10a231882a6e52908642b572326f"
+SRC_URI[stablepatch.sha256sum] = "88e579f74f95ffac30d9d011be98c83e67cf348b9937d2131514a0874bb4413f"
-S = "${WORKDIR}/git"
-CONFIG_NAME_om-gta02 = "gta02_drm_defconfig"
+S = "${WORKDIR}/git"
do_configure_prepend() {
- install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+ install -m 644 ${WORKDIR}/defconfig ${WORKDIR}/defconfig-oe
}