aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch')
-rw-r--r--recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch b/recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch
new file mode 100644
index 0000000000..7f5514503e
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.30.4/055-gta02-leds.patch
@@ -0,0 +1,25 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -227,6 +227,12 @@ config LEDS_BD2802
+ This option enables support for BD2802GU RGB LED driver chips
+ accessed via the I2C bus.
+
++config LEDS_GTA02_VIBRATOR
++ boolean "Vibrator Support for the Openmoko Freerunner GSM phone"
++ depends on LEDS_CLASS && MACH_NEO1973_GTA02
++ help
++ This option enables support for the vibrator on the Openmoko Freerunner.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
++obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
+
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o