aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch')
-rw-r--r--recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch34
1 files changed, 10 insertions, 24 deletions
diff --git a/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch b/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
index 13fe0b0234..47eab0fa7d 100644
--- a/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
+++ b/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
@@ -1,7 +1,9 @@
-From cb8ce54283e64bd30636b7bcd2d7bb4e200825d2 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
-Date: Fri, 7 Aug 2009 12:01:55 +0300
-Subject: [PATCH 04/18] OMAP: Add VRAM manager
+Date: Fri, 7 Aug 2009 09:01:55 +0000 (+0300)
+Subject: OMAP: Add VRAM manager
+X-Git-Url: http://arago-project.org/git/people/?p=vaibhav%2Fti-psp-omap-video.git;a=commitdiff_plain;h=9e5a02f69fe2261ac928aa956add6f1c9f48386d
+
+OMAP: Add VRAM manager
Add a Video RAM manager for OMAP 2 and 3 platforms. VRAM manager is used
to allocate large continuous blocks of SDRAM or SRAM. The features VRAM
@@ -20,33 +22,20 @@ and boot parameter overrides kernel config and board file.
Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
---
- arch/arm/mach-omap2/io.c | 2 +
- arch/arm/plat-omap/include/mach/vram.h | 63 +++
- arch/arm/plat-omap/sram.c | 8 +
- drivers/video/Kconfig | 1 +
- drivers/video/Makefile | 1 +
- drivers/video/omap2/Kconfig | 2 +
- drivers/video/omap2/Makefile | 1 +
- drivers/video/omap2/vram.c | 655 ++++++++++++++++++++++++++++++++
- 8 files changed, 733 insertions(+), 0 deletions(-)
- create mode 100644 arch/arm/plat-omap/include/mach/vram.h
- create mode 100644 drivers/video/omap2/Kconfig
- create mode 100644 drivers/video/omap2/Makefile
- create mode 100644 drivers/video/omap2/vram.c
diff --git a/arch/arm/mach-omap2/io.c b/arch/arm/mach-omap2/io.c
-index 49199a3..f837063 100644
+index 4a08ad3..e5dd736 100644
--- a/arch/arm/mach-omap2/io.c
+++ b/arch/arm/mach-omap2/io.c
-@@ -32,6 +32,7 @@
- #include <mach/sram.h>
+@@ -33,6 +33,7 @@
#include <mach/sdrc.h>
#include <mach/gpmc.h>
+ #include <mach/serial.h>
+#include <mach/vram.h>
#ifndef CONFIG_ARCH_OMAP4 /* FIXME: Remove this once clkdev is ready */
#include "clock.h"
-@@ -240,6 +241,7 @@ void __init omap2_map_common_io(void)
+@@ -246,6 +247,7 @@ void __init omap2_map_common_io(void)
omap2_check_revision();
omap_sram_init();
omapfb_reserve_sdram();
@@ -124,7 +113,7 @@ index 0000000..fe72f81
+
+#endif
diff --git a/arch/arm/plat-omap/sram.c b/arch/arm/plat-omap/sram.c
-index 5eae787..c9b89cd 100644
+index 925f647..cda311b 100644
--- a/arch/arm/plat-omap/sram.c
+++ b/arch/arm/plat-omap/sram.c
@@ -28,6 +28,7 @@
@@ -849,6 +838,3 @@ index 0000000..634ce23
+ omap_vram_sram_start = start;
+ omap_vram_sram_size = size;
+}
---
-1.6.2.4
-