aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-nexusone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-nexusone_git.bb')
-rw-r--r--recipes/linux/linux-nexusone_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/linux/linux-nexusone_git.bb b/recipes/linux/linux-nexusone_git.bb
new file mode 100644
index 0000000000..cf8f656e48
--- /dev/null
+++ b/recipes/linux/linux-nexusone_git.bb
@@ -0,0 +1,30 @@
+require linux.inc
+DEPENDS += "android-image-utils-native"
+
+PV = "2.6.37+${PR}+gitr${SRCREV}"
+PR = "r0"
+
+COMPATIBLE_MACHINE = "nexusone"
+CMDLINE = "root=/dev/mmcblk0p1 rw rootwait noinitrd fbcon=rotate:1"
+
+SRCREV = "87fe2be204fdb40883c508a9d4d9567b40c52300"
+
+SRC_URI = "\
+ git://gitorious.org/htc-msm-2-6-32/leviathan-incoming.git;protocol=git;branch=nexusone \
+ file://defconfig \
+"
+S = "${WORKDIR}/git"
+
+do_deploy_append() {
+ if [ ! -e empty.gz ];then
+ if [ ! -e empty ];then
+ touch empty
+ fi
+ gzip empty
+ fi
+ mkbootimg --kernel ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin \
+ --ramdisk empty.gz \
+ --cmdline "${CMDLINE}" \
+ --base 0x20000000 \
+ --output ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.fastboot
+}