aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-linkstationppc_2.6.28.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-linkstationppc_2.6.28.4.bb')
-rw-r--r--recipes/linux/linux-linkstationppc_2.6.28.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/linux/linux-linkstationppc_2.6.28.4.bb b/recipes/linux/linux-linkstationppc_2.6.28.4.bb
new file mode 100644
index 0000000000..3c15d78e42
--- /dev/null
+++ b/recipes/linux/linux-linkstationppc_2.6.28.4.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linux Kernel for the Buffalo Linkstation HD/HG"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "dtc-native u-boot-mkimage-native"
+COMPATIBLE_MACHINE = "(lsppchd|lsppchg)"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.gz;patch=1 \
+ file://fw-and-powerpc-install.patch;patch=1 \
+ file://defconfig \
+ "
+S = "${WORKDIR}/linux-2.6.28"
+
+require linux.inc
+
+export ARCH="powerpc"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ ARCH=${ARCH} oe_runmake oldconfig
+}