aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-geodegx_2.4.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-geodegx_2.4.24.bb')
-rw-r--r--recipes/linux/linux-geodegx_2.4.24.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-geodegx_2.4.24.bb b/recipes/linux/linux-geodegx_2.4.24.bb
new file mode 100644
index 0000000000..fb42b562cc
--- /dev/null
+++ b/recipes/linux/linux-geodegx_2.4.24.bb
@@ -0,0 +1,26 @@
+# Linux kernel OE build file for the AMD Geode GX processor
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+COMPATIBLE_MACHINE = "geodegx"
+
+KV = "2.4.24"
+DESCRIPTION = "Linux kernel for the AMD Geode GX processor"
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
+ http://www.amd.com/files/connectivitysolutions/geode/Patches_Linux_${KV}_1.00.tar.gz \
+ file://${WORKDIR}/Patches_Linux_${KV}_1.00/linux-${KV}-geode.patch;patch=1 \
+ file://linux-2.4.24-gcc340-fixes.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${KV}"
+
+inherit kernel
+
+ARCH = "i386"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}