aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch')
-rw-r--r--recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch345
1 files changed, 345 insertions, 0 deletions
diff --git a/recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch b/recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch
new file mode 100644
index 0000000000..746a64fe44
--- /dev/null
+++ b/recipes/linux/linux-davinci/dm355-leopard/0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch
@@ -0,0 +1,345 @@
+From a04a493ead5afb10aafe2c0cf57bf9e3bf7aa844 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@openembedded.org>
+Date: Thu, 12 Mar 2009 14:15:42 -0300
+Subject: [PATCH] dm355-leopard: add board file based on board-dm355-evm.c
+
+---
+ arch/arm/mach-davinci/Kconfig | 8 +
+ arch/arm/mach-davinci/Makefile | 2 +
+ arch/arm/mach-davinci/board-dm355-leopard.c | 295 +++++++++++++++++++++++++++
+ 3 files changed, 305 insertions(+), 0 deletions(-)
+ create mode 100644 arch/arm/mach-davinci/board-dm355-leopard.c
+
+diff --git a/arch/arm/mach-davinci/Kconfig b/arch/arm/mach-davinci/Kconfig
+index 0010f2d..85424b8 100644
+--- a/arch/arm/mach-davinci/Kconfig
++++ b/arch/arm/mach-davinci/Kconfig
+@@ -50,6 +50,14 @@ config MACH_SFFSDR
+ Say Y here to select the Lyrtech Small Form Factor
+ Software Defined Radio (SFFSDR) board.
+
++config MACH_DM355_LEOPARD
++ bool "TI DM355 Leopard board"
++ default n
++ depends on ARCH_DAVINCI_DM355
++ help
++ Configure this option to specify the whether the board used
++ for development is a DM355 Leopard board.
++
+ config DAVINCI_MUX
+ bool "DAVINCI multiplexing support"
+ depends on ARCH_DAVINCI
+diff --git a/arch/arm/mach-davinci/Makefile b/arch/arm/mach-davinci/Makefile
+index 6783681..96ef484 100644
+--- a/arch/arm/mach-davinci/Makefile
++++ b/arch/arm/mach-davinci/Makefile
+@@ -19,3 +19,5 @@ obj-$(CONFIG_MACH_DAVINCI_EVM) += board-dm644x-evm.o
+ obj-$(CONFIG_MACH_DAVINCI_DM646X_EVM) += board-dm646x-evm.o
+ obj-$(CONFIG_MACH_DAVINCI_DM355_EVM) += board-dm355-evm.o
+ obj-$(CONFIG_MACH_SFFSDR) += board-sffsdr.o
++obj-$(CONFIG_MACH_DM355_LEOPARD) += board-dm355-leopard.o
++
+diff --git a/arch/arm/mach-davinci/board-dm355-leopard.c b/arch/arm/mach-davinci/board-dm355-leopard.c
+new file mode 100644
+index 0000000..a1e97e8
+--- /dev/null
++++ b/arch/arm/mach-davinci/board-dm355-leopard.c
+@@ -0,0 +1,295 @@
++/*
++ * TI DM355 leopard board support
++ *
++ * Based on board-dm355-evm.c
++ *
++ * This file is licensed under the terms of the GNU General Public
++ * License version 2. This program is licensed "as is" without any
++ * warranty of any kind, whether express or implied.
++ */
++#include <linux/kernel.h>
++#include <linux/module.h>
++#include <linux/init.h>
++#include <linux/dma-mapping.h>
++#include <linux/platform_device.h>
++#include <linux/mtd/mtd.h>
++#include <linux/mtd/partitions.h>
++#include <linux/mtd/nand.h>
++#include <linux/i2c.h>
++#include <linux/io.h>
++#include <linux/gpio.h>
++#include <linux/clk.h>
++#include <linux/spi/spi.h>
++#include <linux/spi/eeprom.h>
++
++#include <asm/setup.h>
++#include <asm/mach-types.h>
++#include <asm/mach/arch.h>
++#include <asm/mach/map.h>
++#include <asm/mach/flash.h>
++
++#include <mach/hardware.h>
++#include <mach/dm355.h>
++#include <mach/psc.h>
++#include <mach/common.h>
++#include <mach/emac.h>
++#include <mach/i2c.h>
++#include <mach/serial.h>
++#include <mach/nand.h>
++#include <mach/mmc.h>
++
++#define DAVINCI_ASYNC_EMIF_CONTROL_BASE 0x01e10000
++#define DAVINCI_ASYNC_EMIF_DATA_CE0_BASE 0x02000000
++
++/* NOTE: this is geared for the standard config, with a socketed
++ * 2 GByte Micron NAND (MT29F16G08FAA) using 128KB sectors. If you
++ * swap chips, maybe with a different block size, partitioning may
++ * need to be changed.
++ */
++#define NAND_BLOCK_SIZE SZ_128K
++
++static struct mtd_partition davinci_nand_partitions[] = {
++ {
++ /* UBL (a few copies) plus U-Boot */
++ .name = "bootloader",
++ .offset = 0,
++ .size = 15 * NAND_BLOCK_SIZE,
++ .mask_flags = MTD_WRITEABLE, /* force read-only */
++ }, {
++ /* U-Boot environment */
++ .name = "params",
++ .offset = MTDPART_OFS_APPEND,
++ .size = 1 * NAND_BLOCK_SIZE,
++ .mask_flags = 0,
++ }, {
++ .name = "kernel",
++ .offset = MTDPART_OFS_APPEND,
++ .size = SZ_4M,
++ .mask_flags = 0,
++ }, {
++ .name = "filesystem1",
++ .offset = MTDPART_OFS_APPEND,
++ .size = SZ_512M,
++ .mask_flags = 0,
++ }, {
++ .name = "filesystem2",
++ .offset = MTDPART_OFS_APPEND,
++ .size = MTDPART_SIZ_FULL,
++ .mask_flags = 0,
++ }
++ /* two blocks with bad block table (and mirror) at the end */
++};
++
++static struct davinci_nand_pdata davinci_nand_data = {
++ .mask_chipsel = BIT(14),
++ .parts = davinci_nand_partitions,
++ .nr_parts = ARRAY_SIZE(davinci_nand_partitions),
++ .ecc_mode = NAND_ECC_HW_SYNDROME,
++ .options = NAND_USE_FLASH_BBT,
++};
++
++static struct resource davinci_nand_resources[] = {
++ {
++ .start = DAVINCI_ASYNC_EMIF_DATA_CE0_BASE,
++ .end = DAVINCI_ASYNC_EMIF_DATA_CE0_BASE + SZ_32M - 1,
++ .flags = IORESOURCE_MEM,
++ }, {
++ .start = DAVINCI_ASYNC_EMIF_CONTROL_BASE,
++ .end = DAVINCI_ASYNC_EMIF_CONTROL_BASE + SZ_4K - 1,
++ .flags = IORESOURCE_MEM,
++ },
++};
++
++static struct platform_device davinci_nand_device = {
++ .name = "davinci_nand",
++ .id = 0,
++
++ .num_resources = ARRAY_SIZE(davinci_nand_resources),
++ .resource = davinci_nand_resources,
++
++ .dev = {
++ .platform_data = &davinci_nand_data,
++ },
++};
++
++static struct davinci_i2c_platform_data i2c_pdata = {
++ .bus_freq = 400 /* kHz */,
++ .bus_delay = 0 /* usec */,
++};
++
++static int dm355leopard_mmc_gpios = -EINVAL;
++
++static void dm355leopard_mmcsd_gpios(unsigned gpio)
++{
++ gpio_request(gpio + 0, "mmc0_ro");
++ gpio_request(gpio + 1, "mmc0_cd");
++ gpio_request(gpio + 2, "mmc1_ro");
++ gpio_request(gpio + 3, "mmc1_cd");
++
++ /* we "know" these are input-only so we don't
++ * need to call gpio_direction_input()
++ */
++
++ dm355leopard_mmc_gpios = gpio;
++}
++
++static struct i2c_board_info dm355leopard_i2c_info[] = {
++ { I2C_BOARD_INFO("dm355leopard_msp", 0x25),
++ .platform_data = dm355leopard_mmcsd_gpios,
++ /* plus irq */ },
++ /* { I2C_BOARD_INFO("tlv320aic3x", 0x1b), }, */
++ /* { I2C_BOARD_INFO("tvp5146", 0x5d), }, */
++};
++
++static void __init leopard_init_i2c(void)
++{
++ davinci_init_i2c(&i2c_pdata);
++
++ gpio_request(5, "dm355leopard_msp");
++ gpio_direction_input(5);
++ dm355leopard_i2c_info[0].irq = gpio_to_irq(5);
++
++ i2c_register_board_info(1, dm355leopard_i2c_info,
++ ARRAY_SIZE(dm355leopard_i2c_info));
++}
++
++static struct resource dm355leopard_dm9000_rsrc[] = {
++ {
++ /* addr */
++ .start = 0x04014000,
++ .end = 0x04014001,
++ .flags = IORESOURCE_MEM,
++ }, {
++ /* data */
++ .start = 0x04014002,
++ .end = 0x04014003,
++ .flags = IORESOURCE_MEM,
++ }, {
++ .flags = IORESOURCE_IRQ
++ | IORESOURCE_IRQ_HIGHEDGE /* rising (active high) */,
++ },
++};
++
++static struct platform_device dm355leopard_dm9000 = {
++ .name = "dm9000",
++ .id = -1,
++ .resource = dm355leopard_dm9000_rsrc,
++ .num_resources = ARRAY_SIZE(dm355leopard_dm9000_rsrc),
++};
++
++static struct platform_device *davinci_leopard_devices[] __initdata = {
++ &dm355leopard_dm9000,
++ &davinci_nand_device,
++};
++
++static struct davinci_uart_config uart_config __initdata = {
++ .enabled_uarts = (1 << 0),
++};
++
++static void __init dm355_leopard_map_io(void)
++{
++ davinci_map_common_io();
++ dm355_init();
++}
++
++static int dm355leopard_mmc_get_cd(int module)
++{
++ if (!gpio_is_valid(dm355leopard_mmc_gpios))
++ return -ENXIO;
++ /* low == card present */
++ return !gpio_get_value_cansleep(dm355leopard_mmc_gpios + 2 * module + 1);
++}
++
++static int dm355leopard_mmc_get_ro(int module)
++{
++ if (!gpio_is_valid(dm355leopard_mmc_gpios))
++ return -ENXIO;
++ /* high == card's write protect switch active */
++ return gpio_get_value_cansleep(dm355leopard_mmc_gpios + 2 * module + 0);
++}
++
++static struct davinci_mmc_config dm355leopard_mmc_config = {
++ .get_cd = dm355leopard_mmc_get_cd,
++ .get_ro = dm355leopard_mmc_get_ro,
++ .wires = 4,
++ .max_freq = 50000000,
++ .caps = MMC_CAP_MMC_HIGHSPEED | MMC_CAP_SD_HIGHSPEED,
++};
++
++/* Don't connect anything to J10 unless you're only using USB host
++ * mode *and* have to do so with some kind of gender-bender. If
++ * you have proper Mini-B or Mini-A cables (or Mini-A adapters)
++ * the ID pin won't need any help.
++ */
++#ifdef CONFIG_USB_MUSB_PERIPHERAL
++#define USB_ID_VALUE 0 /* ID pulled high; *should* float */
++#else
++#define USB_ID_VALUE 1 /* ID pulled low */
++#endif
++
++static struct spi_eeprom at25640a = {
++ .byte_len = SZ_64K / 8,
++ .name = "at25640a",
++ .page_size = 32,
++ .flags = EE_ADDR2,
++};
++
++static struct spi_board_info dm355_leopard_spi_info[] __initconst = {
++ {
++ .modalias = "at25",
++ .platform_data = &at25640a,
++ .max_speed_hz = 10 * 1000 * 1000, /* at 3v3 */
++ .bus_num = 0,
++ .chip_select = 0,
++ .mode = SPI_MODE_0,
++ },
++};
++
++static __init void dm355_leopard_init(void)
++{
++ struct clk *aemif;
++
++ gpio_request(1, "dm9000");
++ gpio_direction_input(1);
++ dm355leopard_dm9000_rsrc[2].start = gpio_to_irq(1);
++
++ aemif = clk_get(&dm355leopard_dm9000.dev, "aemif");
++ clk_enable(aemif);
++ clk_put(aemif);
++
++ platform_add_devices(davinci_leopard_devices,
++ ARRAY_SIZE(davinci_leopard_devices));
++ leopard_init_i2c();
++ davinci_serial_init(&uart_config);
++
++ /* NOTE: NAND flash timings set by the UBL are slower than
++ * needed by MT29F16G08FAA chips ... EMIF.A1CR is 0x40400204
++ * but could be 0x0400008c for about 25% faster page reads.
++ */
++
++ gpio_request(2, "usb_id_toggle");
++ gpio_direction_output(2, USB_ID_VALUE);
++ /* irlml6401 switches over 1A in under 8 msec */
++ setup_usb(500, 8);
++
++ davinci_setup_mmc(0, &dm355leopard_mmc_config);
++ davinci_setup_mmc(1, &dm355leopard_mmc_config);
++
++ dm355_init_spi0(BIT(0), dm355_leopard_spi_info,
++ ARRAY_SIZE(dm355_leopard_spi_info));
++}
++
++static __init void dm355_leopard_irq_init(void)
++{
++ davinci_irq_init();
++}
++
++MACHINE_START(DM355_LEOPARD, "DaVinci DM355 leopard")
++ .phys_io = IO_PHYS,
++ .io_pg_offst = (__IO_ADDRESS(IO_PHYS) >> 18) & 0xfffc,
++ .boot_params = (0x80000100),
++ .map_io = dm355_leopard_map_io,
++ .init_irq = dm355_leopard_irq_init,
++ .timer = &davinci_timer,
++ .init_machine = dm355_leopard_init,
++MACHINE_END
+--
+1.6.1.2
+