aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linphone
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linphone')
-rw-r--r--recipes/linphone/files/b64_assert.patch11
-rw-r--r--recipes/linphone/linphone_3.1.0.bb2
2 files changed, 12 insertions, 1 deletions
diff --git a/recipes/linphone/files/b64_assert.patch b/recipes/linphone/files/b64_assert.patch
new file mode 100644
index 0000000000..1e89610b8a
--- /dev/null
+++ b/recipes/linphone/files/b64_assert.patch
@@ -0,0 +1,11 @@
+--- linphone-3.1.0/oRTP/src/b64.c.orig 2009-04-13 23:04:35.000000000 -0600
++++ linphone-3.1.0/oRTP/src/b64.c 2009-04-13 23:05:00.000000000 -0600
+@@ -205,7 +205,7 @@
+ /* characters[3] is the right-most 6 bits of src[2] */
+ characters[3] = (char)(src[2] & 0x3f);
+
+-#ifndef __WATCOMC__
++#ifdef XXXX
+ assert(characters[0] >= 0 && characters[0] < 64);
+ assert(characters[1] >= 0 && characters[1] < 64);
+ assert(characters[2] >= 0 && characters[2] < 64);
diff --git a/recipes/linphone/linphone_3.1.0.bb b/recipes/linphone/linphone_3.1.0.bb
index bebaa169e2..e5e1258885 100644
--- a/recipes/linphone/linphone_3.1.0.bb
+++ b/recipes/linphone/linphone_3.1.0.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
PR = "r1"
-DEPENDS = "intltool libosip2 speex libogg alsa-lib readline libexosip2"
+DEPENDS = "intltool libosip2 speex libogg alsa-lib readline libexosip2 gtk+"
DEPENDS_${PN} = "liblinphone"
DEPENDS_${PN}c = "liblinphone readline"
DEPENDS_liblinphone = "libmediastreamer libortp libosip2"