aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lighttpd/lighttpd/configure.in.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lighttpd/lighttpd/configure.in.patch')
-rw-r--r--recipes/lighttpd/lighttpd/configure.in.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/lighttpd/lighttpd/configure.in.patch b/recipes/lighttpd/lighttpd/configure.in.patch
new file mode 100644
index 0000000000..772103cf76
--- /dev/null
+++ b/recipes/lighttpd/lighttpd/configure.in.patch
@@ -0,0 +1,34 @@
+Index: lighttpd-1.4.13/configure.in
+===================================================================
+--- lighttpd-1.4.13.orig/configure.in 2006-10-09 18:19:34.000000000 +0200
++++ lighttpd-1.4.13/configure.in 2007-02-13 18:42:34.000000000 +0100
+@@ -250,23 +250,23 @@
+ [WITH_PCRE=$withval],[WITH_PCRE=yes])
+ AC_MSG_RESULT([$WITH_PCRE])
+
+-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
++if test "$WITH_PCRE" != "no"; then
+ AC_PATH_PROG(PCRECONFIG, pcre-config)
+
+- if test x"$PCRECONFIG" != x; then
++# if test x"$PCRECONFIG" != x; then
+ PCRE_LIB=`$PCRECONFIG --libs`
+ CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
+ OLDLIBS="$LIBS"
+ LIBS="$LIBS $PCRE_LIB"
+- AC_CHECK_LIB(pcre, pcre_compile, [
++# AC_CHECK_LIB(pcre, pcre_compile, [
+ AC_CHECK_HEADERS([pcre.h], [
+ AC_DEFINE([HAVE_LIBPCRE], [1], [libpcre])
+ AC_DEFINE([HAVE_PCRE_H], [1])
+ ])
+- ])
++# ])
+ LIBS="$OLDLIBS"
+- fi
+-fi
++# fi
++fi
+
+ AC_SUBST(PCRE_LIB)
+